Back to overview
Degraded
@tugboat.qa email is down for maintenance
May 24 at 12:08pm EDT
Affected services
www.tugboatqa.com
Resolved
May 24 at 12:31pm EDT
The migration is complete.
Affected services
www.tugboatqa.com
Created
May 24 at 12:08pm EDT
We are currently migrating the email delivery for all @tugboat.qa email addresses. If you need to reach support or other accounts, please use our primary domain, @tugboatqa.com.
Affected services
www.tugboatqa.com