Back to overview
Degraded
@tugboatqa.com email is down for maintenance
May 24 at 07:41am EDT
Affected services
www.tugboatqa.com
Resolved
May 24 at 12:03pm EDT
We have completed migration of all @tugboatqa.com addresses.
Affected services
www.tugboatqa.com
Created
May 24 at 07:41am EDT
We are currently migrating the email delivery for all @tugboatqa.com email addresses. If you need to reach support or other accounts, please use our secondary domain, @tugboat.qa.
Affected services
www.tugboatqa.com