Back to overview
Degraded

Incomplete query results

Jan 13 at 08:52am EST
Affected services
Dashboard
API
Previews
Visual Diffs
Lighthouse Reports

Resolved
Jan 24 at 10:26am EST

We've completed migrating all job logs to the new database schema. Thank you for your patience. Please reach out to support@tugboatqa.com with any questions or concerns.

Updated
Jan 16 at 04:53pm EST

Job logs are still not fully migrated to the new schema. The migration was creating database instability. For this reason, we will need to perform some preliminary database cleanup operations prior to resuming the migration of job logs. Consequently, you may see some missing logs for some historical jobs. New jobs are unaffected. Thank you for your patience. If you have specific logs that you need access to, please reach out to support@tugboatqa.com.

Updated
Jan 14 at 04:15pm EST

We are continuing with one data migration that is time consuming. There may be some historical Job logs that do not load properly until this operation has completed. We will update you when the migration is complete.

Updated
Jan 13 at 03:47pm EST

Most services are fully operational now. There is one final cleanup task that is slow going which affects the availability of statistics and trends.

Updated
Jan 13 at 09:35am EST

Everyone, thank you for your patience. We’ve identified the root cause, and are working on a fix. More details on the underlying issue: there was a schema change that resulted in a mismatch between newly created objects versus extant objects. Newly created objects work fine with this schema change, but existing objects need to be converted. No data is lost as a result of this bug. We are working on the upgrade script right now, and will be testing it and then deploying it as soon as possible. Again, thank you for your patience!

Created
Jan 13 at 08:52am EST

We have discovered an issue with the most recent release that impacts database queries, showing incomplete or empty results. We have no reason to believe there is any data loss at this time.